PHP 7 Compatible Store Locator v4.0: New Benefits & Tighter WordPress Integration

 - By 
Issues this Update Fixes:
– PHP 7.0+ & PHP 7.2+ compatibility both for base plugin and addons
– Geocoding improvements reported by a number of users (no more red or pink-highlighted locations in admin location management)

**Upgrade now, avoid any current/future compatibility issues as sites upgrade to PHP 7.0+ **
**Helpful Note: Updating to Store Locator v4.0+ is easy for current users
– Don’t worry about losing current locations because Store Locator v4.0 uses the same database as before. Deactivating / activating / upgrading Store Locator never deletes any location data.
– Map settings, custom CSS (stored in ‘/wp-content/uploads/sl-uploads/’) won’t be affected by updating either
Store Locator v4.0+: PHP 7 compatible Store Locator, featuring tighter integration with WordPress and many new benefits

Store Locator v4.0+: PHP 7 compatible Store Locator, featuring tighter integration with WordPress and many new benefits

WordPress Store Locator v4.0 is a PHP 7 compatible store locator that’s now ready following a thorough update & improvement.

WordPress requested these updates in order to allow Store Locator to continue providing all the great benefits you’ve had for many years. Additionally, new addon features are now available, many of which topped users’ request list for a while.

Changes

All addons, labeled v2.0 or higher, are official WordPress plugins, meaning that they are much easier to install and update than ever before (much less FTP needed now).

Additionally, it more tightly integrates into WordPress’s platform. This allows Store Locator to take advantage of WordPress’s ongoing security enhancements with each new update.

The previous way of installing and updating addons — via our Addons Marketplace — will not be available to new users since WordPress’s admin plugin interface now provides the installation and updating functionality for the base plugin and addons.

Now, Addons Platform Lite v2.0 — which powers all Store Locator addons, just without the Addons Marketplace — will be provided with Store Locator v4.0+.

New Benefits

So many new benefits for developers and their clients exist, but here a some important ones of note:

Fully PHP 7 Compatibility:

PHP, just like WordPress, Store Locator, Google Maps, and any other platform, continues to evolve year by year. PHP 7 is the latest iteration of PHP, thus, stay on top of the eventual shift of web hosting over to PHP 7+. This PHP 7 compatible Store Locator helps accomplishes this nicely.

Still on PHP 5.2? Store Locator still supports that too currently. Would suggest bumping up your PHP version to at least PHP 5.3+, with PHP 7.0+ being preferable, however.

Custom Ordering of Location Results:

One of the many great features provided by the Power Options addon. A popular request that is available for your benefit.

New Addons:

Power Options, as previously mentioned, incorporates several new heavily requested features that give you more power to customize your Store Locator just as envisioned. Developer Console, similarly, provides the tools and guidance to create custom addons that can change & enhance the way that one’s Store Locator operates.

Painstaking effort and thought has gone into building Store Locator v4.0+ based on feedback — the responses from users so far have been positive as it has helped provide the benefits, functionality, and compatibility needed to serve their clients’ needs.

Confident it will do the same for you. There are even more new benefits in the works, so more improvements are coming.

Dynamic Text Translating:

WPML 3.2+ and Polylang plugins provide dynamic text translating — Store Locator v4.0+ integrates with both.

Dynamic translating essentially is being able to translate customizable texts in a plugin’s settings. For Store Locator, these customizable, translatable texts can be found on the MapDesigner admin settings page.

Search

Cart

Number of items in cart: 4